Не приходят письма в exim CentOS 7 с ПУ VestaCP - Geek-Speak

Не приходят письма в exim CentOS 7 с ПУ VestaCP

Главная Форумы SOFTWARE Tuning Systems Не приходят письма в exim CentOS 7 с ПУ VestaCP

Просмотр 2 сообщений - с 1 по 2 (из 2 всего)
  • Автор
    Сообщения
  • #1431
    Esmertec
    Хранитель

    После обновления пакета exim до версии 4.94-1.el7 на CentOS 7, в панели управления VestaCP перестает работать почта. Письма не приходят получателю… Чтоб решить эту проблему нужно откатиться на предыдущую версию пакета (4.93-3.el7). Чтоб откатиться вводим команды:
    # wget http://repo.geek-speak.perm.ru/rpm/exim-4.93-3.el7.x86_64.rpm
    # rpm -Uvh --oldpackage exim-4.93-3.el7.x86_64.rpm

    Чтоб запретить дальнейшее обновление этого пакета, можно установить versionlock утилиту для управления пакетами в CentOS7. Для этого устанавливаем сам пакет:
    # yum -y install yum-versionlock

    Послу установки пакета можно использовать следующие команды для работы:

    # yum versionlock package-name-here
    # yum versionlock package1 package2
    # yum versionlock add package-wildcard
    # yum versionlock add package1*
    # yum versionlock [command] package1*

    Нам понадобится команда блокировки пакета exim:
    # yum versionlock exim

    После этого можно спокойно делать yum update не боясь замены нашего пакета!

    Как появилась эта ошибка? К сожалению проект vestacp — умирает. И первоначальные разработчики забили на него… В новом пакете exim изменились конфигурации пакета, о которых ПУ ни чего не знает, по этому пакет начинает работать не правильно. Подробнее о vestacp можно почитать в оф. топике форума. Топик с подробным описанием проблемы exim можно посмотреть тут.

    Так же смотрите мои темы связанные с VestaCP:
    ОБНОВЛЯЕМ PHP 5.6 ДО ВЕРСИИ 7.3 НА ПАНЕЛИ УПРАВЛЕНИЯ VESTACP
    ОБНОВЛЕНИЕ SQL MARIADB 5.5 ДО ВЕРСИИ 10.4 НА VESTACP
    УСТАНОВКА IMAGICK (IMAGEMAGICK) НА CENTOS 7
    ВОССТАНОВЛЕНИЕ FAIL2BAN НА VESTACP CENTOS 7.7.1908
    ROUNDCUBE ОШИБКА СЕРВЕРА: STATUS: INTERNAL ERROR OCCURRED.

    #1758
    Esmertec
    Хранитель

    Еще один пакет который примерно так же умер как exim — phpMyAdmin… В репо CentOS7 отсутствуют обновленные пакеты:
    php-symfony4-config >= 4.4.9
    php-symfony4-dependency-injection >= 4.4.9
    php-symfony4-expression-language >= 4.4.9
    Возможно на текущий момент, а возможно насовсем, RHEL свернул проект CentOS, похоже после этого пакеты начали потихоньку отмирать.

    --> Проверка сценария
    ---> Пакет php-nikic-fast-route.noarch 0:1.3.0-6.el7.remi помечен для установки
    ---> Пакет php-phpmyadmin-motranslator5.noarch 0:5.2.0-1.el7.remi помечен для установки
    ---> Пакет phpMyAdmin.noarch 0:5.1.0~rc2-1.el7.remi помечен как обновление
    --> Обработка зависимостей: php-symfony4-config >= 4.4.9 пакета: phpMyAdmin-5.1.0~rc2-1.el7.remi.noarch
    --> Обработка зависимостей: php-symfony4-dependency-injection >= 4.4.9 пакета: phpMyAdmin-5.1.0~rc2-1.el7.remi.noarch
    --> Обработка зависимостей: php-symfony4-expression-language >= 4.4.9 пакета: phpMyAdmin-5.1.0~rc2-1.el7.remi.noarch
    --> Проверка зависимостей окончена
    Ошибка: Пакет: phpMyAdmin-5.1.0~rc2-1.el7.remi.noarch (remi-test)
                Необходимо: php-symfony4-expression-language >= 4.4.9
                Установлено: php-symfony4-expression-language-4.1.13-2.el7.remi.noarch (@remi)
                    php-symfony4-expression-language = 4.1.13-2.el7.remi
                Доступно: php-symfony4-expression-language-4.1.13-1.el7.remi.noarch (remi)
                    php-symfony4-expression-language = 4.1.13-1.el7.remi
    Ошибка: Пакет: phpMyAdmin-5.1.0~rc2-1.el7.remi.noarch (remi-test)
                Необходимо: php-symfony4-config >= 4.4.9
                Установлено: php-symfony4-config-4.1.13-2.el7.remi.noarch (@remi)
                    php-symfony4-config = 4.1.13-2.el7.remi
                Доступно: php-symfony4-config-4.1.13-1.el7.remi.noarch (remi)
                    php-symfony4-config = 4.1.13-1.el7.remi
    Ошибка: Пакет: phpMyAdmin-5.1.0~rc2-1.el7.remi.noarch (remi-test)
                Необходимо: php-symfony4-dependency-injection >= 4.4.9
                Установлено: php-symfony4-dependency-injection-4.1.13-2.el7.remi.noarch (@remi)
                    php-symfony4-dependency-injection = 4.1.13-2.el7.remi
                Доступно: php-symfony4-dependency-injection-4.1.13-1.el7.remi.noarch (remi)
                    php-symfony4-dependency-injection = 4.1.13-1.el7.remi
     Вы можете попробовать --skip-broken чтобы обойти проблему
     Вы можете попробовать запустить: rpm -Va --nofiles --nodigest
    [root@geek-speak tmp]# yum versionlock phpMyAdmin
    Загружены модули: fastestmirror, getpagespeed, versionlock
    Adding versionlock on: 0:phpMyAdmin-5.0.4-1.el7.remi
    versionlock added: 1
    [root@geek-speak tmp]# yum update
    Загружены модули: fastestmirror, getpagespeed, versionlock
    Loading mirror speeds from cached hostfile
     * base: mirror.corbina.net
     * epel: epel.mirror.liteserver.nl
     * extras: mirror.sale-dedic.com
     * remi: mirror.reconn.ru
     * remi-php74: mirror.reconn.ru
     * remi-safe: mirror.reconn.ru
     * remi-test: mirror.reconn.ru
     * updates: mirror.surf
    Excluding 2 updates due to versionlock (use "yum versionlock status" to show them)
    No packages marked for update
Просмотр 2 сообщений - с 1 по 2 (из 2 всего)
  • Для ответа в этой теме необходимо авторизоваться.
Авторизация
*
*
Регистрация
*
*
*
Пароль не введен
*
Генерация пароля