Настройка USB модема в Hilink на OpenWRT 19.07.3

Главная Форумы SOFTWARE System settings Настройка USB модема в Hilink на OpenWRT 19.07.3

Просмотр 15 сообщений - с 16 по 30 (из 52 всего)
  • Автор
    Сообщения
  • #1652
    E-tec
    Хранитель

      Поставьте пакет, чтоб убедиться, что модем определяется в openwrt, команда должна отобразить, что модем подключен

      # opkg update
      # opkg install usbutils
      # lsusb

      #1653
      pavlo1c
      Участник

        root@RT-AC58U:/# lsusb
        Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
        Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
        Bus 001 Device 002: ID 12d1:1f01 Huawei Technologies Co., Ltd. E353/E3131 (Mass storage mode)
        Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
        Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
        root@RT-AC58U:/#

        #1654
        E-tec
        Хранитель

          кажется я понял в чем проблема…

          # opkg install kmod-usb-net kmod-usb-net-rndis kmod-usb2 kmod-usb3
          # reboot
          #1655
          pavlo1c
          Участник

            сделал, толку нет 🙁

            #1656
            E-tec
            Хранитель

              сделал, толку нет

              а команда dmesg | grep usb что отображает?

              #1657
              pavlo1c
              Участник

                /etc$ dmesg | grep usb
                [ 0.028848] usbcore: registered new interface driver usbfs
                [ 0.028912] usbcore: registered new interface driver hub
                [ 0.028994] usbcore: registered new device driver usb
                [ 0.045358] tcsr 194b000.tcsr: setting usb hs phy mode select = e700e7
                [ 9.610528] usb usb2: We don’t know the algorithms for LPM for this host, disabling LPM.
                [ 9.681930] usb usb4: We don’t know the algorithms for LPM for this host, disabling LPM.
                [ 9.960333] usb 1-1: new high-speed USB device number 2 using xhci-hcd
                [ 19.254073] usbcore: registered new interface driver cdc_wdm
                [ 19.407607] usbcore: registered new interface driver usbserial
                [ 19.408652] usbcore: registered new interface driver usbserial_generic
                [ 19.413981] usbserial: USB Serial support registered for generic
                [ 19.446634] usbcore: registered new interface driver cdc_ether
                [ 19.465050] usbcore: registered new interface driver cdc_ncm
                [ 19.482136] usbcore: registered new interface driver huawei_cdc_ncm
                [ 19.513490] usbcore: registered new interface driver rndis_host

                #1658
                E-tec
                Хранитель

                  а драйвера из мануала все установлены? по сути должна быть еще одна строка на подобии: cdc ether 1-1:1.0 eth2: register … bla…bla…bla
                  возможно сам модем не переведен в этот режим, на сколько знаю некоторые модемы нужно перепрошить, чтоб перевести в этот режим

                  #1659
                  pavlo1c
                  Участник

                    из этой статьи все по порядку установлено
                    модем прошит и переведен в cdc режим, так как пропал с винды напрочь, до этого в rndis в винде работал, прошивка hilink.

                    #1660
                    E-tec
                    Хранитель

                      я думаю стоит погуглить следующие строки в инте:

                      [ 9.610528] usb usb2: We don’t know the algorithms for LPM for this host, disabling LPM.
                      [ 9.681930] usb usb4: We don’t know the algorithms for LPM for this host, disabling LPM.

                      еще вариант перепрошить модем обратно в сток, и попробовать подключить, возможно openwrt сама как пк подхватит этот модем в cdc режиме. Тут точно сказать сложно где проблема… Если есть другой юсб модем можно его попробовать подключить в роутер, чтоб убедиться, что проблема не в прошивке, и не в железе роутера.

                      #1661
                      pavlo1c
                      Участник

                        еще вариант перепрошить модем обратно в сток, и попробовать подключить, возможно openwrt сама как пк подхватит этот модем в cdc режиме. Тут точно сказать сложно где проблема… Если есть другой юсб модем можно его попробовать подключить в роутер, чтоб убедиться, что проблема не в прошивке, и не в железе роутера.

                        В том и проблема, что в этом режиме CDC винда не видит этого модема теперь, кроме его флэшки и перепрошить нельзя 🙁
                        Советуют как раз в роутеру подцепить или магнитоле (но ГУ не увидела его), чтобы переключить режим назад и тогда может увидится 🙁

                        #1662
                        pavlo1c
                        Участник

                          Переключал на CDC днем ранее, тоесть модем работал.

                          #1663
                          E-tec
                          Хранитель

                            что в этом режиме CDC винда не видит этого модема теперь

                            винда должна видеть этот модем в cdc режиме, как новая сетевая карта по сути..

                            Переключал на CDC днем ранее, тоесть модем работал.

                            т.е. на пк он все же работал или на роутере? У меня просто есть небольшое подозрение, что он немного закирпичился)) Слишком странное поведение. Если сейчас в винде он определяется только как флешка, да и судя по логам с роутера так же, по моему стоит начинать немного печалиться…

                            #1664
                            pavlo1c
                            Участник

                              винда такого режима не знает

                              сейчас восстановил и прошил назад, винда теперь видит
                              и прикол в том, что в этом режиме так сказать винды, роутер видит его теперь как eth2, а в CDC походу не дружат они.
                              Про сообщение “We don’t know the algorithms for LPM for this host, disabling LPM.”
                              я так понял это в openwrt была проблема в 18 версии и походу осталась, когда usb 3.0 работает как 2.0 или 3.0 по uas он решает поддержка есть или нет и если что то не так он пытается ее врубить один фиг и вот такое выдает.

                              Методы etc/modules.d/usb-storage не работают и походу никто так и не смог этого решить 🙁

                              удалил kmod-usb-storage-uas, но врядли это решение (скорее всего всё будет на usb работать в режиме 2.0, но я для другого особо не использую его)

                              в логах пишет что все фейсы зарегал, но cdc не пашет, а rndis пашет 🙂 :
                              usbcore: registered new interface driver cdc_ether
                              [ 19.763277] usbcore: registered new interface driver cdc_ncm
                              [ 19.778547] usbcore: registered new interface driver huawei_cdc_ncm
                              [ 19.807821] PPP generic driver version 2.4.2
                              [ 19.808904] NET: Registered protocol family 24
                              [ 19.812951] usbcore: registered new interface driver rndis_host

                              #1665
                              E-tec
                              Хранитель

                                когда usb 3.0 работает как 2.0 или 3.0 по uas он решает поддержка есть или нет

                                чисто в теории это должно было пофикситься патчаси ядра kmod-usb2 kmod-usb3

                                скорее всего всё будет на usb работать в режиме 2.0

                                дак юсб модем на сколько я понимаю с usb 2.0 разъемом, или неужели с 3.0?

                                в логах пишет что все фейсы зарегал, но cdc не пашет, а rndis пашет

                                Это еще не факт, покажет только замер скорости интернета через этот модем, в cdc режиме нет ограничения скорости, в отличии от rndis

                                #1760
                                armars
                                Участник

                                  добрый день

                                  у меня такая же проблема как у pavlo1c

                                  у меня dlink dir 320 nru

                                  openwrt 19.07.7

                                   

                                  установил kmod-usb-net kmod-usb-net-rndis kmod-usb2

                                  и все заработало

                                  kmod-usb3 не стал устанавливать потому что на dir 320 USB3 порта нет

                                  так что добавьте в шапке и эти пакеты чтоб в комментариях не искать

                                   

                                  спасибо 🙂

                                  PS
                                  пакета libusb нет

                                  есть только libusb-1.0

                                   

                                  • Ответ изменён 3 года, 1 месяц назад пользователем armars.
                                Просмотр 15 сообщений - с 16 по 30 (из 52 всего)
                                • Для ответа в этой теме необходимо авторизоваться.
                                Авторизация
                                *
                                *
                                Регистрация
                                *
                                *
                                *
                                Пароль не введен
                                *
                                Генерация пароля