Базовая настройка DHCPv4 на маршрутизаторе Cisco - Geek-Speak

Главная Форумы SOFTWARE Cisco lessons and setup Базовая настройка DHCPv4 на маршрутизаторе Cisco

Просмотр 1 сообщения - с 1 по 1 (всего 1)
  • Автор
    Сообщения
  • #1045
    Esmertec
    Хранитель

    Топология

    Таблица адресации

    Устройство Интерфейс IP-адрес Маска подсети Шлюз по умолчанию
    R1 G0/0 192.168.0.1 255.255.255.0 N/A
    G0/1 192.168.1.1 255.255.255.0 N/A
    S0/0/0 (DCE) 192.168.2.253 255.255.255.252 N/A
    R2 S0/0/0 192.168.2.254 255.255.255.252 N/A
    S0/0/1 (DCE) 209.165.200.226 255.255.255.224 N/A
    ISP S0/0/1 209.165.200.225 255.255.255.224 N/A
    PC-A NIC DHCP DHCP DHCP
    PC-B NIC DHCP DHCP DHCP

    Задачи

    Часть 1. Построение сети и настройка базовых параметров устройства

    Часть 2. Выполнение настройки DHCPv4-сервера и агента-ретранслятора DHCP

    Исходные данные/сценарий

    Протокол динамической конфигурации сетевого узла (DHCP) — сетевой протокол, позволяющий сетевым администраторам управлять и автоматизировать назначение IP-адресов. Без использования DHCP администратору необходимо вручную назначать и настраивать IP-адреса, предпочтительные DNS-серверы и шлюзы по умолчанию. По мере увеличения сети и перемещении устройств из одной внутренней сети в другую это становится административной проблемой.

    В предложенном сценарии размеры компании увеличились, и сетевые администраторы больше не имеют возможности назначать IP-адреса для устройств вручную. Ваша задача заключается в настройке маршрутизатора R2 для назначения IPv4-адресов в двух разных подсетях, подключённых к маршрутизатору R1.

    Примечание. В данной лабораторной работе содержится минимальный набор команд, необходимых для настройки DHCP. Список требуемых команд приведён в приложении A. Проверьте свои знания — настройте устройства, не обращаясь к информации, приведённой в приложении.

    Примечание. Убедитесь, что предыдущие настройки маршрутизаторов и коммутаторов удалены, и они не имеют загрузочной конфигурации. Если вы не уверены в этом, обратитесь к преподавателю.

    Необходимые ресурсы:

    • 3 маршрутизатора (Cisco 1941 под управлением ОС Cisco IOS 15.2(4) M3 (образ universal) или аналогичная модель);
    • 2 коммутатора (Cisco 2960 под управлением ОС Cisco IOS 15.0(2), образ lanbasek9 или аналогичная модель);
    • 2 ПК (под управлением ОС Windows 7, Vista или XP с программой эмуляции терминала, например Tera Term);
    • консольные кабели для настройки устройств Cisco IOS через консольные порты;
    • кабели Ethernet и последовательные кабели в соответствии с топологией.

    Часть 1: Построение сети и настройка базовых параметров устройства

    В первой части лабораторной работы вам предстоит создать топологию сети и настроить основные параметры на маршрутизаторах и коммутаторах, такие как пароли и IP-адреса. Также вам предстоит настроить параметры IP для компьютеров в приведённой топологии.

    Шаг 1: Подключите кабели в сети в соответствии с топологией.

    Шаг 2: Настройте базовые параметры каждого маршрутизатора.

    a. Отключите DNS-поиск.
    b. Настройте имя устройства в соответствии с топологией.
    c. Назначьте class в качестве зашифрованного пароля доступа к привилегированному режиму EXEC.
    d. Назначьте cisco в качестве паролей консоли и VTY.
    e. Настройте logging synchronous, чтобы сообщения от консоли не могли прерывать ввод команд.
    f. Назначьте IP-адреса всем интерфейсам маршрутизатора в соответствии с таблицей адресации.
    g. Настройте последовательный интерфейс DCE на маршрутизаторах R1 и R2 с тактовой частотой
    128000.
    h. Сконфигурируйте EIGRP для R1.

    R1(config)# router eigrp 1
    R1(config-router)# network 192.168.0.0 0.0.0.255
    R1(config-router)# network 192.168.1.0 0.0.0.255
    R1(config-router)# network 192.168.2.252 0.0.0.3
    R1(config-router)# no auto-summary

    i. Настройте EIGRP и маршрут по умолчанию для интернет-провайдера на маршрутизаторе R2.

    R2(config)# router eigrp 1
    R2(config-router)# network 192.168.2.252 0.0.0.3
    R2(config-router)# redistribute static
    R2(config-router)# exit
    R2(config)# ip route 0.0.0.0 0.0.0.0 209.165.200.225

    j. Настройте суммарный статический маршрут на ISP для доступа к сетям маршрутизаторов R1 и R2.

    ISP(config)# ip route 192.168.0.0 255.255.252.0 209.165.200.226

    k. Сохраните текущую конфигурацию в загрузочную конфигурацию.

    Шаг 3: Выполните проверку сетевого соединения между маршрутизаторами.

    При неудачных эхо-запросах между маршрутизаторами прежде чем переходить к следующему шагу исправьте возникшие ошибки. Используйте команды show ip route и show ip interface brief, чтобы определить возможные неполадки.

    Шаг 4: Убедитесь, что ПК на узлах настроены для работы DHCP.

    Часть 2: Настройка DHCPv4-сервера и агента-ретранслятора DHCP

    Для того чтобы автоматически назначить адресную информацию в сети, вам необходимо настроить маршрутизатор R2 в качестве сервера DHCPv4, а маршрутизатор R1 в качестве агента-ретранслятора.

    Шаг 1: Выполните настройку сервера DHCPv4 на маршрутизаторе R2.

    На маршрутизаторе R2 необходимо создать пул DHCP-адресов для каждой локальной сети маршрутизатора R1. Используйте имя пула R1G0 для интерфейса G0/0 LAN и R1G1 для интерфейса G0/1 LAN. Также вам нужно исключить адреса, которые не будут назначаться из пула адресов. Исключать адреса рекомендуется в первую очередь, чтобы предотвратить их случайную аренду для других устройств.

    Исключите первые девять адресов из каждой локальной сети маршрутизатора R1, начиная с .1. Все другие адреса должны быть доступны в пуле DHCP. Убедитесь, что каждый пул DHCP содержит шлюз по умолчанию, домен lab.com, сервер DNS (209.165.200.225), а срок аренды составляет два дня.

    В строках ниже запишите команды, необходимые для настройки служб DHCP на маршрутизаторе R2, включая те, что требуются для исключения DHCP-адресов и создания пулов DHCP.

    Примечание. Команды, необходимые для выполнения заданий второй части лабораторной работы, приведены в приложении A. Для того чтобы проверить свои знания, попробуйте настроить DHCP на маршрутизаторах R1 и R2, не обращаясь к приложению.

    Шаг 2: Настройте маршрутизатор R1 в качестве агента ретрансляции.

    Настройте вспомогательные IP-адреса на маршрутизаторе R1, чтобы переслать все DHCP-запросы на сервер DHCP маршрутизатора R2.

    Шаг 3: Запишите IP-параметры для компьютеров PC-A и PC-B.

    На компьютерах PC-A и PC-B выполните команду ipconfig /all, чтобы убедиться, что компьютеры получили информацию об IP-адресах от DHCP-сервера маршрутизатора R2.

    Шаг 4: Проверьте работу служб DHCP и аренды адресов на маршрутизаторе R2.

    1. На маршрутизаторе R2 выполните команду show ip dhcp binding, чтобы просмотреть список арендованных DHCP адресов.
    2. На маршрутизаторе R2 выполните команду show ip dhcp show statistics, чтобы отобразить статистику пула DHCP и активность сообщений.
    3. На маршрутизаторе R2 выполните команду show ip dhcp pool, чтобы просмотреть настройки пула DHCP.
    4. На маршрутизаторе R2 выполните команду show run | section dhcp, чтобы просмотреть конфигурацию DHCP в текущей конфигурации.
    5. На маршрутизаторе R2 выполните команду show run interface для интерфейсов G0/0 и G0/1, чтобы просмотреть настройки ретранслятора DHCP в текущей конфигурации.

    Сводная таблица интерфейсов маршрутизаторов

    Сводная информация об интерфейсах маршрутизаторов
    Модель маршрутизатора Интерфейс Ethernet №1 Интерфейс Ethernet №2 Последовательный интерфейс №1 Последовательный интерфейс №2
    1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
    2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    Примечание. Чтобы узнать, каким образом настроен маршрутизатор, изучите интерфейсы с целью определения типа маршрутизатора и количества имеющихся на нём интерфейсов. Эффективного способа перечисления всех комбинаций настроек для каждого класса маршрутизаторов не существует.
    В данной таблице содержатся идентификаторы возможных сочетаний Ethernet и последовательных (Serial) интерфейсов в устройстве. В таблицу не включены какие-либо иные типы интерфейсов, даже если на определённом маршрутизаторе они присутствуют. В качестве примера можно привести интерфейс ISDN BRI. Строка в скобках — это принятое сокращение, которое можно использовать в командах Cisco IOS для представления интерфейса.

    Приложение А. Команды настройки DHCP
    Маршрутизатор R1

    R1(config)# interface g0/0
    R1(config-if)# ip helper-address 192.168.2.254
    R1(config-if)# exit
    R1(config-if)# interface g0/1
    R1(config-if)# ip helper-address 192.168.2.254

    Маршрутизатор R2

    R2(config)# ip dhcp excluded-address 192.168.0.1 192.168.0.9
    R2(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9
    R2(config)# ip dhcp pool R1G1
    R2(dhcp-config)# network 192.168.1.0 255.255.255.0
    R2(dhcp-config)# default-router 192.168.1.1
    R2(dhcp-config)# dns-server 209.165.200.225
    R2(dhcp-config)# domain-name lab.com
    R2(dhcp-config)# lease 2
    R2(dhcp-config)# exit
    R2(config)# ip dhcp pool R1G0
    R2(dhcp-config)# network 192.168.0.0 255.255.255.0
    R2(dhcp-config)# default-router 192.168.0.1
    R2(dhcp-config)# dns-server 209.165.200.225
    R2(dhcp-config)# domain-name lab.com
    R2(dhcp-config)# lease 2

    Ты знаешь, что такое безумие? Безумие - это точное повторение одного и того же действия, раз за разом, в надежде на изменение.

Просмотр 1 сообщения - с 1 по 1 (всего 1)
  • Для ответа в этой теме необходимо авторизоваться.
Авторизация
*
*
Регистрация
*
*
*
Пароль не введен
*
Генерация пароля