Базовая настройка DHCPv4 на коммутаторе Cisco - Geek-Speak

Главная Форумы SOFTWARE Cisco lessons and setup Базовая настройка DHCPv4 на коммутаторе Cisco

Просмотр 1 сообщения - с 1 по 1 (всего 1)
  • Автор
    Сообщения
  • #1047
    Esmertec
    Хранитель

    Топология

    Таблица адресации

    Устройство Интерфейс IP-адрес Маска подсети
    R1 G0/1 192.168.1.10 255.255.255.0
    Lo0 209.165.200.225 255.255.255.224
    S1 VLAN 1 192.168.1.1 255.255.255.0
    VLAN 2 192.168.2.1 255.255.255.0

    Задачи

    Часть 1. Построение сети и настройка базовых параметров устройства Часть 2. Изменение параметров SDM

    • Настройка на маршрутизаторе S1 параметра SDM на lanbase-routing.

    Часть 3. Настройка DHCPv4

    • Настройка DHCPv4 для сети VLAN 1.
    • Проверка DHCPv4 и соединения.

    Часть 4. Настройка DHCP для нескольких VLAN

    • Назначение портов сети VLAN 2.
    • Настройка DHCPv4 для сети VLAN 2.
    • Проверка DHCPv4 и соединения.

    Часть 5. Активация IP-маршрутизации

    • Активируйте на коммутаторе IP-маршрутизацию.
    • Создание статических маршрутов.

    Исходные данные/Сценарий

    Коммутатор Cisco 2960 может работать в качестве сервера DHCPv4. Сервер Cisco DHCPv4 назначает и управляет IPv4-адресами из указанных пулов адресов, связанных с конкретными сетями VLAN и виртуальными интерфейсами коммутатора. Коммутатор Catalyst 2960 может функционировать в качестве устройства 3-го уровня и маршрутизировать данные между сетями VLAN и ограниченным количеством статических маршрутов. В данной работе вам предстоит настроить DHCPv4 на коммутаторе Cisco 2960 как для одной, так и для нескольких сетей VLAN, активировать маршрутизацию на коммутаторе для обеспечения связи между сетями VLAN, а также добавить статические маршруты для обеспечения связи между всеми узлами.

    Примечание. В данной лабораторной работе содержится минимальный набор команд, необходимых для настройки DHCP. Список требуемых команд приведён в приложении A. Проверьте свои знания — настройте устройства, не обращаясь к информации, приведённой в приложении.

    Примечание. Убедитесь, что предыдущие настройки маршрутизаторов и коммутаторов удалены, и они не имеют загрузочной конфигурации. Если вы не уверены в этом, обратитесь к преподавателю.

    Необходимые ресурсы

    • 1 маршрутизатор (Cisco 1941 с универсальным образом M3 под управлением ОС Cisco IOS 15.2(4) или аналогичная модель);
    • 2 коммутатора (Cisco 2960 под управлением ОС Cisco IOS 15.0(2), образ lanbasek9 или аналогичная модель);
    • 2 ПК (под управлением ОС Windows 7, Vista или XP с программой эмуляции терминала, например Tera Term);
    • консольные кабели для настройки устройств Cisco IOS через консольные порты;
      кабели Ethernet, расположенные в соответствии с топологией.

    Часть 1: Построение сети и настройка базовых параметров устройства

    Шаг 1: Подключите кабели в сети в соответствии с топологией.

    Шаг 2: Настройте основные параметры устройств.

    1. Присвойте устройствам имена в соответствии с топологией.
    2. Отключите поиск DNS.
    3. Установите class в качестве пароля привилегированного режима. В качестве паролей консоли и виртуального терминала vty установите cisco.
    4. Назначьте IP-адреса интерфейсам G0/1 и Lo0 маршрутизатора R1 в соответствии с таблицей адресации.
    5. Назначьте IP-адреса интерфейсам VLAN 1 и VLAN 2 коммутатора S1 в соответствии с таблицей адресации.
    6. Сохраните файл текущей конфигурации в файл загрузочной конфигурации.

    Часть 2: Изменение параметра SDM

    Диспетчер базы данных коммутатора Cisco (Switch Database Manager, SDM) содержит несколько шаблонов для коммутатора 2960. Шаблоны можно применять для выполнения определённых функций в зависимости от того, как коммутатор используется в сети. В данной лабораторной работе используется шаблон SDM lanbase-routing, чтобы разрешить коммутатору маршрутизировать данные между сетями VLAN, а также разрешить поддержку статической маршрутизации.

    Шаг 1: Отобразите параметр SDM на коммутаторе S1.

    На коммутаторе S1 выполните команду show sdm prefer в привилегированном режиме. Если шаблон не был изменен, то используются заводские настройки, шаблон default. Шаблон default не поддерживает статическую маршрутизацию. При включённой IPv6-адресации шаблоном по умолчанию будет dual-ipv4-and-ipv6.
    S1# show sdm prefer

    The current	template is	"default" template.	
    The selected template	optimizes the resources in	
    the switch to support	this level of features for	
    0 routed	interfaces and	255 VLANs.	
    	number	of	unicast mac	addresses:	8K
    	number	of	IPv4 IGMP	groups:	0.25K
    	number	of	IPv4/MAC qos aces:	0.125k
    	number	of	IPv4/MAC security aces:	0.375k

    Шаг 2: Измените параметр SDM на коммутаторе S1.

    a. Настройте параметр SDM на lanbase-routing. (Если lanbase-routing является текущим шаблоном, перейдите к части 3). В режиме глобальной конфигурации выполните команду sdm prefer lanbase-routing.

    S1(config)# sdm prefer lanbase-routing
    
    Changes to the running SDM preferences have been stored, but cannot take effect until the next reload.
    Use 'show sdm prefer' to see what SDM preference is currently active.

    b. Для активации шаблона коммутатор нужно перезагрузить.

    S1# reload
    
    System configuration has been modified. Save? [yes/no]: no Proceed with reload? [confirm]

    Примечание. Новый шаблон будет использоваться после перезагрузки, даже если текущая конфигурация не была сохранена. Для того чтобы сохранить текущую конфигурацию после внесения изменений в систему, выберите yes.

    Шаг 3: Убедитесь, что шаблон lanbase-routing загружен.

    Для проверки, загружен ли на маршрутизаторе S1 шаблон lanbase-routing, выполните команду show sdm prefer.

    S1# show sdm prefer
    
    The current template is "lanbase-routing" template. The selected template optimizes the resources in the switch to support this level of features for 0 routed interfaces and 255 VLANs.
    
    number of unicast mac addresses:	4K
    number of IPv4 IGMP groups + multicast routes:	0.25K
    number of IPv4 unicast routes:	0.75K
    number of directly-connected IPv4 hosts:	0.75K
    number of indirect IPv4 routes:	16
    number of IPv6 multicast groups:	0.375k
    number of directly-connected IPv6 addresses:	0.75K
    number of indirect IPv6 unicast routes:	16
    number of IPv4 policy based routing aces:	0
    number of IPv4/MAC qos aces:	0.125k
    number of IPv4/MAC security aces:	0.375k
    number of IPv6 policy based routing aces:	0
    number of IPv6 qos aces:	0.375k
    number of IPv6 security aces:	127

    Часть 3: Настройка DHCPv4

    В части 3 вам предстоит настроить DHCPv4 для VLAN 1, проверить настройки IP на узловых компьютерах, чтобы подтвердить успешную работу DHCP, а также проверить наличие подключения у всех устройств в сети VLAN 1.

    Шаг 1: Настройте DHCP для сети VLAN 1.

    1. Исключите первые десять допустимых адресов узлов из сети 192.168.1.0/24.
    2. Создайте пул DHCP с именем DHCP1.
    3. Для доступных адресов назначьте сеть 192.168.1.0/24.
    4. Укажите в качестве шлюза по умолчанию: 192.168.1.1.
    5. Укажите в качестве адреса сервера DNS: 192.168.1.9.
    6. Настройте срок аренды — три дня.
    7. Сохраните файл текущей конфигурации в файл загрузочной конфигурации.

    Шаг 2: Проверка DHCP и соединения.

    a. На компьютерах PC-A и PC-B откройте командную строку и выполните команду ipconfig. Если IP-информация отсутствует или представлена не полностью, выполните команду ipconfig /release, а после неё команду ipconfig /renew.

    b. Проверьте подключение, отправив эхо-запросы от компьютера PC-A на шлюз по умолчанию, компьютер PC-B и маршрутизатор R1.

    Часть 4: Настройка DHCPv4 для нескольких сетей VLAN

    В части 4 вам предстоит назначить порт PC-A в VLAN 2, настроить DHCPv4 для сети VLAN 2, обновить конфигурацию IP компьютера PC-A для проверки DHCPv4, а также проверить соединение в пределах сети VLAN.

    Шаг 1: Назначьте порт сети VLAN 2.

    Разместите порт F0/6 в сети VLAN 2.

    Шаг 2: Настройте DHCPv4 для сети VLAN 2

    a. Исключите первые десять допустимых адресов узлов из сети 192.168.2.0.
    b. Создайте пул DHCP под названием DHCP2.
    c. Для доступных адресов назначьте сеть 192.168.2.0/24.
    d. Укажите в качестве шлюза по умолчанию: 192.168.2.1.
    e. Укажите в качестве адреса сервера DNS: 192.168.2.9.
    f. Настройте срок аренды — три дня.
    g. Сохраните файл текущей конфигурации в файл загрузочной конфигурации.

    Шаг 3: Проверьте DHCPv4 и соединение.

    a. На компьютере PC-A откройте командную строку и выполните команду ipconfig /release, а затем команду ipconfig /renew.
    b. Проверьте соединение, отправив эхо-запросы от компьютера PC-A на шлюз по умолчанию сети VLAN 2 и компьютер PC-B.
    c. Выполните команду show ip route на коммутаторе S1.

    Часть 5: Активация IP-маршрутизации

    В части 5 вам предстоит включить IP-маршрутизацию на коммутаторе, которая необходима для обмена данными между сетями VLAN. Для обеспечения связи между всеми сетями, на коммутаторе S1 и маршрутизаторе R1 необходимо реализовать статические маршруты.

    Шаг 1: Включите IP-маршрутизацию на коммутаторе S1.

    a. Для того чтобы активировать маршрутизацию на коммутаторе S1, используйте команду ip-routing в режиме глобальной конфигурации
    S1(config)# ip routing

    b. Проверьте наличие подключения между сетями VLAN.
    c. Просмотрите информацию в таблице маршрутизации S1.
    d. Просмотрите информацию в таблице маршрутизации R1.
    e. Успешно ли проходит эхо-запрос от компьютера PC-A на маршрутизатор R1? Успешно ли отправляется эхо-запрос от узла PC-A на интерфейс Lo0?

    Шаг 2: Назначьте статические маршруты.

    После включения IP-маршрутизации коммутатор сможет маршрутизировать данные между сетями VLAN, назначенных на коммутаторе. Для обеспечения связи между всеми сетями VLAN и маршрутизатором в таблицы маршрутизации коммутатора и маршрутизатора следует добавить статические маршруты.

    a. На коммутаторе S1 создайте статический маршрут по умолчанию к маршрутизатору R1. Ниже напишите команду, которую вы использовали.
    b. На маршрутизаторе R1 создайте статический маршрут до сети VLAN 2. Ниже напишите команду, которую вы использовали.
    c. Просмотрите информацию в таблице маршрутизации S1.
    d. Просмотрите информацию в таблице маршрутизации R1.
    e. Успешно ли проходит эхо-запрос от компьютера PC-A на маршрутизатор R1?

    Сводная таблица интерфейсов маршрутизаторов

    Сводная информация об интерфейсах маршрутизаторов
    Модель маршрутизатора Интерфейс Ethernet №1 Интерфейс Ethernet №2 Последовательный интерфейс №1 Последовательный интерфейс №2
    1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
    2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    Примечание. Чтобы узнать, каким образом настроен маршрутизатор, изучите интерфейсы с целью определения типа маршрутизатора и количества имеющихся на нём интерфейсов. Эффективного способа перечисления всех комбинаций настроек для каждого класса маршрутизаторов не существует.
    В данной таблице содержатся идентификаторы возможных сочетаний Ethernet и последовательных (Serial) интерфейсов в устройстве. В таблицу не включены какие-либо иные типы интерфейсов, даже если на определённом маршрутизаторе они присутствуют. В качестве примера можно привести интерфейс ISDN BRI. Строка в скобках — это принятое сокращение, которое можно использовать в командах Cisco IOS для представления интерфейса.

    Приложение А. Команды настройки

    Настройка DHCPv4

    S1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10
    S1(config)# ip dhcp pool DHCP1
    S1(dhcp-config)# network 192.168.1.0 255.255.255.0
    S1(dhcp-config)# default-router 192.168.1.1
    S1(dhcp-config)# dns-server 192.168.1.9
    S1(dhcp-config)# lease 3

    Настройка DHCPv4 для нескольких сетей VLAN

    S1(config)# interface f0/6
    S1(config-if)# switchport access vlan 2
    S1(config)# ip dhcp excluded-address 192.168.2.1 192.168.2.10
    S1(config)# ip dhcp pool DHCP2
    S1(dhcp-config)# network 192.168.2.0 255.255.255.0
    S1(dhcp-config)# default-router 192.168.2.1
    S1(dhcp-config)# dns-server 192.168.2.9
    S1(dhcp-config)# lease 3

    Активация IP-маршрутизации

    S1(config)# ip routing
    S1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.10
    R1(config)# ip route 192.168.2.0 255.255.255.0 g0/1

    Ты знаешь, что такое безумие? Безумие - это точное повторение одного и того же действия, раз за разом, в надежде на изменение.

Просмотр 1 сообщения - с 1 по 1 (всего 1)
  • Для ответа в этой теме необходимо авторизоваться.
Авторизация
*
*
Регистрация
*
*
*
Пароль не введен
*
Генерация пароля