Настройка базовых параметров маршрутизатора с помощью интерфейса командной строк - Geek-Speak

Главная Форумы SOFTWARE Cisco lessons and setup Настройка базовых параметров маршрутизатора с помощью интерфейса командной строк

В этой теме 0 ответов, 1 участник, последнее обновление  Esmertec 3 нед., 3 дн. назад.

Просмотр 1 сообщения - с 1 по 1 (всего 1)
  • Автор
    Сообщения
  • #642

    Esmertec
    Хранитель

    Топология:

    Таблица адресации:

    Устройство Интерфейс IP-адрес Маска подсети Шлюз по умолчанию
    R1 G0/0 192.168.0.1 255.255.255.0 N/A
    G0/1 192.168.1.1 255.255.255.0 N/A
    PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
    PC-B NIC 192.168.0.3 255.255.255.0 192.168.1.1

    Задачи:

    Часть 1. Настройка топологии и установка исходного состояния устройства

    • Подключите кабели к оборудованию в соответствии с топологией сети.
    • Выполните инициализацию и перезагрузку маршрутизатора и коммутатора.

    Часть 2. Конфигурация устройств и проверка подключения

    • Настройте статическую информацию IPv4 на интерфейсах ПК.
    • Настройте базовые параметры маршрутизатора.
    • Проверьте сетевое соединение.
    • Настройте на маршрутизаторе протокол SSH.

    Часть 3. Отображение сведений о маршрутизаторе

    • Загрузите из маршрутизатора данные об аппаратном и программном обеспечении.
    • Интерпретируйте выходные данные загрузочной конфигурации.
    • Интерпретируйте выходные данные таблицы маршрутизации.
    • Проверьте состояние интерфейсов.

    Часть 4. Конфигурация протокола IPv6 и проверка подключения

    Исходные данные/Сценарий:
    Это комплексная лабораторная работа, нацеленная на повторение ранее изученных команд IOS для маршрутизатора. В первой и второй частях вам предстоит подключить кабели к оборудованию и выполнить базовую настройку конфигураций и параметров IPv4-интерфейса на маршрутизаторе.

    В третьей части вам нужно будет настроить удалённое подключение к маршрутизатору с помощью протокола SSH, а также использовать команды IOS для получения от устройства данных, необходимых для того, чтобы ответить на вопросы о маршрутизаторе. В четвёртой части от вас потребуется настроить протокол IPv6 на маршрутизаторе таким образом, чтобы компьютер PC-B мог получить IP-адрес, а затем проверить подключение.

    В целях повторения в этой лабораторной работе представлены команды, необходимые для определённых конфигураций маршрутизатора.

    Примечание. Убедитесь, что информация из маршрутизаторов и коммутаторов удалена, и они не содержат файлов загрузочной конфигурации. Процедуры, необходимые для инициализации и перезагрузки устройств, приводятся в приложении А.

    Необходимые ресурсы:

    • 1 маршрутизатор (Cisco 1941 с универсальным образом M3 под управлением ОС Cisco IOS 15.2(4) или аналогичная модель);
    • 1 коммутатор (Cisco 2960 под управлением ОС Cisco IOS 15.0(2), образ lanbasek9 или аналогичная модель);
    • 2 ПК;
    • консольные кабели для настройки устройств Cisco IOS через консольные порты;
    • кабели Ethernet, расположенные в соответствии с топологией.

    Примечание. Интерфейсы Gigabit Ethernet на маршрутизаторах Cisco 1941 определяют скорость автоматически, поэтому между маршрутизатором и компьютером PC-B можно использовать прямой кабель Ethernet. При использовании маршрутизатора Cisco другой модели может потребоваться кроссовый кабель Ethernet.

    Часть 1: Настройка топологии и инициализация устройств
    Шаг 1: Подключите кабели в сети в соответствии с топологией.

    1. Подключите устройства в соответствии с топологией и проведите все необходимые кабели.
    2. Включите все устройства в топологии.

    Шаг 2: Выполните инициализацию и перезагрузку маршрутизатора и коммутатора.
    Примечание. В приложении А подробно изложен процесс инициализации и перезагрузки устройств.

    Часть 2: Настройка устройств и проверка подключения

    Шаг 1: Настройте интерфейсы ПК.

    1. На PC-A настройте IP-адрес, маску подсети и параметры шлюза по умолчанию.
    2. На PC-B настройте IP-адрес, маску подсети и параметры шлюза по умолчанию.

    Шаг 2: Настройте маршрутизатор.
    a. Подключитесь к маршрутизатору с помощью консольного подключения и активируйте привилегированный режим.

    Router> enable 
    Router#

    b. Войдите в режим глобальной конфигурации маршрутизатора.
    Router# config terminal
    Router(config)#

    c. Назначьте маршрутизатору имя устройства.
    Router(config)# hostname R1

    d. Отключите поиск DNS, чтобы предотвратить попытки маршрутизатора неверно преобразовать введённые команды так, как если бы они были узлами.
    R1(config)# no ip domain-lookup

    e. Пароли должны содержать не менее 10 символов.
    R1(config)# security passwords min-length 10

    f. Назначьте cisco12345 в качестве зашифрованного пароля привилегированного режима.
    R1(config)# enable secret cisco12345

    g. В качестве пароля консоли назначьте ciscoconpass, установите лимит времени, активируйте вход в систему и добавьте команду logging synchronous. Команда logging synchronous позволяет синхронизировать выходные данные отладки и программного обеспечения Cisco IOS, а также запрещает этим сообщениям прерывать ввод команд с клавиатуры.
    R1(config)# line con 0
    R1(config-line)# password ciscoconpass
    R1(config-line)# exec-timeout 5 0
    R1(config-line)# login
    R1(config-line)# logging synchronous
    R1(config-line)# exit
    R1(config)#

    h. В качестве пароля vty назначьте ciscovtypass, установите лимит времени, активируйте вход в систему и добавьте команду logging synchronous.
    R1(config)# line vty 0 4
    R1(config-line)# password ciscovtypass
    R1(config-line)# exec-timeout 5 0
    R1(config-line)# login
    R1(config-line)# logging synchronous
    R1(config-line)# exit
    R1(config)#

    i. Зашифруйте незашифрованные пароли.
    R1(config)# service password-encryption

    j. Создайте баннер с предупреждением о запрете несанкционированного доступа к устройству.
    R1(config)# banner motd #Unauthorized access prohibited!#

    k. Настройте IP-адрес и описание интерфейса. Активируйте оба интерфейса на маршрутизаторе.
    R1(config)# int g0/0
    R1(config-if)# description Connection to PC-B
    R1(config-if)# ip address 192.168.0.1 255.255.255.0
    R1(config-if)# no shutdown
    R1(config-if)# int g0/1
    R1(config-if)# description Connection to S1
    R1(config-if)# ip address 192.168.1.1 255.255.255.0
    R1(config-if)# no shutdown
    R1(config-if)#exit
    R1(config)#exit
    R1#

    l. Настройте часы на маршрутизаторе.
    R1# clock set 17:00:00 18 Feb 2013

    m. Сохраните файл текущей конфигурации в файл загрузочной конфигурации.
    R1# copy running-config startup-config

    Destination filename [startup-
    config]? Building configuration…
    [OK]
    R1#

    Шаг 3: Проверьте сетевое соединение.
    a. Из командной строки компьютера PC-B отправьте эхо-запрос на компьютер PC-A.

    Примечание. Для успешной передачи эхо-запросов может потребоваться отключение брандмауэра.

    b. Настройте удалённый доступ к маршрутизатору R1 от компьютера PC-A с помощью клиента Tera Term службы Telnet.

    Откройте Tera Term и введите IP-адрес интерфейса G0/1 маршрутизатора R1 на узле (Host): поле
    Tera Term: окно создания нового соединения (New Connection). Убедитесь, что выбран пункт Telnet, затем нажмите OK, чтобы подключиться к маршрутизатору.

    Шаг 4: Настройте маршрутизатор для доступа по протоколу SSH.
    a. Активируйте подключения SSH и создайте пользователя в локальной базе данных маршрутизатора.
    R1# configure terminal
    R1(config)# ip domain-name geek-speak.ru
    R1(config)# username admin privilege 15 secret adminpass1
    R1(config)# line vty 0 4
    R1(config-line)# transport input ssh
    R1(config-line)# login local R1(config-line)# exit
    R1(config)# crypto key generate rsa modulus 1024
    R1(config)# exit

    b. Настройте удалённый доступ к маршрутизатору R1 от компьютера PC-A с помощью клиента Tera Term по протоколу SSH.

    Откройте Tera Term и введите IP-адрес интерфейса G0/1 маршрутизатора R1 на узле (Host): поле
    Tera Term: окно создания нового соединения (New Connection). Убедитесь, что выбран пункт SSH, затем нажмите OK, чтобы подключиться к маршрутизатору.

    Часть 3: Отображение данных маршрутизатора
    В третьей части вам предстоит использовать команду show в сеансе SSH, чтобы получить информацию из маршрутизатора.

    Шаг 1: Установите сеанс SSH с маршрутизатором R1.
    На компьютере PC-B с помощью Tera Term создайте сеанс SSH с маршрутизатором R1 по IP-адресу 192.168.0.1 и войдите в систему, используя имя пользователя admin и пароль adminpass1.

    Шаг 2: Получите основные данные об аппаратном и программном обеспечении.
    a. Используйте команду show version, чтобы увидеть основные данные об аппаратном и программном обеспечении.

    b. Зачастую команды show могут выводить несколько экранов данных. Фильтрация выходных данных позволяет пользователю отображать лишь нужные разделы выходных данных. Чтобы включить команду фильтрации, после команды show введите прямую черту (|), после которой следует ввести параметр и выражение фильтрации. Чтобы отобразить все строки выходных данных, которые содержат выражение фильтрации, можно согласовать выходные данные с оператором фильтрации с помощью ключевого слова include. Настройте фильтрацию для команды show version и используйте команду show version | include register.

    Шаг 3: Отобразите загрузочную конфигурацию.
    Выполните команду show startup-config на маршрутизатор. Используйте show startup-config | begin vty.

    Шаг 4: Отобразите таблицу маршрутизации на маршрутизаторе.
    Выполните команду show ip route на маршрутизаторе.

    Шаг 5: Отобразите на маршрутизаторе сводный список интерфейсов.
    Выполните команду show ip interface brief на маршрутизаторе.

    Часть 4: Настройка протокола IPv6 и проверка подключения

    Шаг 1: Назначьте IPv6-адреса интерфейсу G0/0 маршрутизатора R1 и включите IPv6-маршрутизацию.
    Примечание. Назначение IPv6-адрес в дополнение к IPv4-адресам на интерфейсе называют двойным стеком, поскольку активным является как протокол IPv4, так и протокол IPv6. Благодаря включению IPv6-маршрутизации одноадресной передачи на маршрутизаторе R1 компьютер PC-B получает сетевой IPv6-префикс для интерфейса G0/0 маршрутизатора R1 и может автоматически настраивать свой IPv6-адрес и шлюз по умолчанию.

    a. Назначьте интерфейсу G0/0 глобальный индивидуальный IPv6-адрес, в дополнение
    к индивидуальному адресу на интерфейсе назначьте локальный адрес канала и включите IPv6-маршрутизацию.
    R1# configure terminal
    R1(config)# interface g0/0
    R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
    R1(config-if)# ipv6 address fe80::1 link-local
    R1(config-if)# no shutdown
    R1(config-if)# exit
    R1(config)# ipv6 unicast-routing
    R1(config)# exit

    b. Чтобы проверить параметры IPv6 на маршрутизаторе R1 выполните команду show ipv6 int brief.

    c. На компьютере PC-B выполните команду ipconfig, чтобы проверить настройки IPv6.

    От компьютера PC-B отправьте эхо-запрос на локальный адрес канала шлюза по умолчанию маршрутизатора R1.

    От компьютера PC-B отправьте эхо-запрос на индивидуальный IPv6-адрес маршрутизатора R1 2001:db8:acad:a::1.

    Сводная таблица интерфейсов маршрутизаторов

    Сводная информация об интерфейсах маршрутизаторов
    Модель маршрутизатора Интерфейс Ethernet №1 Интерфейс Ethernet №2 Последовательный интерфейс №1 Последовательный интерфейс №2
    1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    1900 Gigabit Ethernet0/0 (G0/0) Gigabit Ethernet0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
    2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    2900 Gigabit Ethernet0/0 (G0/0) Gigabit Ethernet0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
    Примечание . Чтобы узнать, каким образом настроен маршрутизатор, изучите интерфейсы с целью определения типа маршрутизатора и количества имеющихся на нём интерфейсов. Эффективного способа перечисления всех комбинаций настроек для каждого класса маршрутизаторов не существует. В данной таблице содержатся идентификаторы возможных сочетаний Ethernet и последовательных (Serial) интерфейсов в устройстве. В таблицу не включены какие-либо иные типы интерфейсов, даже если на определённом маршрутизаторе они присутствуют. В качестве примера можно привести интерфейс ISDN BRI. Строка в скобках — это принятое сокращение, которое можно использовать в командах Cisco IOS для представления интерфейса.

    Приложение А. Инициализация и перезагрузка маршрутизатора и коммутатора

    Шаг 1: Выполните инициализацию и перезагрузку маршрутизатора.

    a. Подключитесь к маршрутизатору с помощью консольного подключения и активируйте привилегированный режим.
    Router> enable
    Router#

    b. Введите команду erase startup-config, чтобы удалить файл загрузочной конфигурации из NVRAM.
    Router# erase startup-config
    Erasing the nvram filesystem will remove all configuration files! Continue?
    [confirm] [OK]
    Erase of nvram: complete
    Router#

    c. Выполните команду reload, чтобы удалить устаревшую информацию о конфигурации из памяти. По запросу перезагрузки нажмите клавишу Enter, чтобы подтвердить перезагрузку. (Чтобы прервать перезагрузку, нажмите любую клавишу.)
    Router# reload
    Proceed with reload? [confirm]
    *Nov 29 18:28:09.923: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.

    Примечание. Возможно, появится запрос о сохранении текущей конфигурации перед перезагрузкой маршрутизатора. Введите no и нажмите клавишу Enter.
    System configuration has been modified. Save? [yes/no]: no

    d. После перезагрузки маршрутизатора появится запрос о входе в диалоговое окно начальной конфигурации. Введите no и нажмите клавишу Enter.
    Would you like to enter the initial configuration dialog? [yes/no]: no

    e. Появится запрос о прекращении автоматической установки (autoinstall). Введите yes, затем нажмите клавишу Enter.
    Would you like to terminate autoinstall? [yes]: yes

    Шаг 2: Выполните инициализацию и перезагрузку коммутатора.
    a. Подключитесь к коммутатору с помощью консольного подключения и войдите в привилегированный режим EXEC.
    Switch> enable
    Switch#

    b. Воспользуйтесь командой show flash, чтобы определить, были ли созданы сети VLAN на коммутаторе.
    Switch# show flash
    Directory of flash:/

    2 -rwx 1919 Mar 1 1993 00:06:33 +00:00 private-config.text
    3 -rwx 1632 Mar 1 1993 00:06:33 +00:00 config.text
    4 -rwx 13336 Mar 1 1993 00:06:33 +00:00 multiple-fs
    5 -rwx 11607161 Mar 1 1993 02:37:06 +00:00 c2960-lanbasek9-mz.150-2.SE.bin
    6 -rwx 616 Mar 1 1993 00:07:13 +00:00 vlan.dat

    32514048 bytes total (20886528 bytes free)
    Switch#

    c. Если во флеш-памяти обнаружен файл vlan.dat, удалите его.
    Switch# delete vlan.dat
    Delete filename [vlan.dat]?

    d. Появится запрос о проверке имени файла. На данном этапе можно изменить имя файла или нажать клавишу Enter, если имя введено верно.

    e. Появится запрос о подтверждении удаления этого файла. Нажмите клавишу Enter, чтобы подтвердить удаление. (Чтобы прервать удаление, нажмите любую клавишу.)
    Delete flash:/vlan.dat?
    [confirm] Switch#

    f. Введите команду erase startup-config, чтобы удалить файл загрузочной конфигурации из NVRAM. Появится запрос о подтверждении удаления файла конфигурации. Нажмите клавишу Enter, чтобы подтвердить удаление этого файла. (Чтобы прервать операцию, нажмите любую клавишу.)
    Switch# erase startup-config

    Erasing the nvram filesystem will remove all configuration files! Continue?
    [confirm] [OK]
    Erase of nvram: complete
    Switch#

    g. Перезагрузите коммутатор, чтобы удалить устаревшую информацию о конфигурации из памяти. Появится запрос о подтверждении перезагрузки коммутатора. Нажмите клавишу Enter, чтобы продолжить перезагрузку. (Чтобы прервать перезагрузку, нажмите любую клавишу.)
    Switch# reload
    Proceed with reload? [confirm]

    Примечание. Возможно, появится запрос о сохранении текущей конфигурации перед перезагрузкой маршрутизатора. Введите no и нажмите клавишу Enter.
    System configuration has been modified. Save? [yes/no]: no

    h. После перезагрузки коммутатора появится запрос о входе в диалоговое окно начальной конфигурации. Введите no и нажмите клавишу Enter.
    Would you like to enter the initial configuration dialog? [yes/no]: no
    Switch>

    • Тема изменена 3 нед. назад пользователем  Esmertec. Причина: UPD 3.04.19 Редактирование статьи

    Ты знаешь, что такое безумие? Безумие - это точное повторение одного и того же действия, раз за разом, в надежде на изменение.

Просмотр 1 сообщения - с 1 по 1 (всего 1)

Для ответа в этой теме необходимо авторизоваться.