Конфигурация сетей VLAN и транковых каналов Cisco - Geek-Speak

Главная Форумы SOFTWARE Cisco lessons and setup Конфигурация сетей VLAN и транковых каналов Cisco

В этой теме 0 ответов, 1 участник, последнее обновление  Esmertec 3 нед., 6 дн. назад.

Просмотр 1 сообщения - с 1 по 1 (всего 1)
  • Автор
    Сообщения
  • #699

    Esmertec
    Хранитель

    Топология

    Таблица адресации

    Устройство Интерфейс IP-адрес Маска подсети Шлюз по умолчанию
    S1 VLAN 1 192.168.1.11 255.255.255.0 N/A
    S2 VLAN 1 192.168.1.12 255.255.255.0 N/A
    PC-A Сетевой адаптер 192.168.10.3 255.255.255.0 192.168.10.1
    PC-B Сетевой адаптер 192.168.10.4 255.255.255.0 192.168.10.1
    PC-C Сетевой адаптер 192.168.20.3 255.255.255.0 192.168.20.1

    Задачи

    Часть 1. Построение сети и настройка базовых параметров устройства
    Часть 2. Создание виртуальных локальных сетей и назначение портов коммутатора
    Часть 3. Поддержка назначения портов VLAN и базы данных VLAN
    Часть 4. Конфигурация транкового канала стандарта 802.1Q между коммутаторами
    Часть 5. Удаление базы данных VLAN

    Исходные данные/сценарий

    В целях повышения производительности сети большие широковещательные домены 2-го уровня делят на домены меньшего размера. Для этого современные коммутаторы используют виртуальные локальные сети (VLAN). Также сети VLAN можно использовать для определения узлов, между которыми возможен обмен данными, что позволяет повысить уровень безопасности. Сети VLAN облегчают процесс проектирования сети, обеспечивающей помощь в достижении целей организации.

    Транковые каналы сети VLAN используются для распространения сетей VLAN по различным устройствам. Транковые каналы разрешают передачу трафика из множества сетей VLAN через один канал, не нанося вред идентификации и сегментации сети VLAN.

    В этой лабораторной работе вам предстоит создать сети VLAN на обоих коммутаторах в топологии, назначить сети VLAN в порты доступа на коммутаторе, проверить корректность работы сетей VLAN, а затем создать транковый канал сети VLAN между двумя коммутаторами, чтобы узлы в пределах одной сети VLAN могли обмениваться данными по транку вне зависимости от того, к какому коммутатору подключён узел.

    Примечание. Убедитесь, что информация из коммутаторов удалена, и они не содержат конфигураций загрузки. Если вы не уверены в этом, обратитесь к преподавателю.

    Необходимые ресурсы

    • 2 коммутатора (Cisco 2960 под управлением ОС Cisco IOS 15.0(2), образ lanbasek9 или аналогичная модель);
    • 3 компьютера;
    • консольные кабели для настройки устройств Cisco IOS через консольные порты;
    • кабели Ethernet, расположенные в соответствии с топологией.

    Часть 1: Построение сети и настройка базовых параметров устройства

    В первой части лабораторной работы вам предстоит создать топологию сети и настроить базовые параметры для узлов ПК и коммутаторов.

    Шаг 1: Подключите кабели в сети в соответствии с топологией.

    Подключите устройства в соответствии с топологией и проведите все необходимые кабели.

    Шаг 2: Выполните инициализацию и перезагрузку коммутаторов.

    Шаг 3: Настройте базовые параметры каждого коммутатора.

    1. Отключите поиск DNS.
    2. Присвойте имена устройствам в соответствии с топологией.
    3. Назначьте class в качестве пароля привилегированного режима EXEC.
    4. Активируйте вход и назначьте в качестве пароля cisco для консоли и VTY.
    5. Настройте logging synchronous для консольного канала.
    6. Настройте баннер MOTD (сообщение дня) для предупреждения пользователей о запрете несанкционированного доступа.
    7. Настройте IP-адрес, указанный в таблице адресации для сети VLAN 1, на обоих коммутаторах.
    8. Используя права администратора, отключите все неиспользуемые порты на коммутаторе.
    9. Сохраните текущую конфигурацию в загрузочную конфигурацию.

    Шаг 4: Настройте узлы ПК.

    Адреса узлов ПК можно посмотреть в таблице адресации.

    Шаг 5: Проверка соединения.

    Проверьте способность компьютеров обмениваться эхо-запросами.

    Примечание. Для успешной передачи эхо-запросов может потребоваться отключение брандмауэра.

    Часть 2: Создание сетей VLAN и назначение портов коммутатора

    Во второй части лабораторной работы вам необходимо создать сети VLAN для учащихся, преподавателей и руководства на обоих коммутаторах. Затем вам нужно назначить сети VLAN соответствующему интерфейсу. Для проверки параметров конфигурации используйте команду show vlan.

    Шаг 1: Создайте сети VLAN на коммутаторах.

    a. Создайте сети VLAN на коммутаторе S1.

    S1(config)# vlan 10
    S1(config-vlan)# name Student
    S1(config-vlan)# vlan 20
    S1(config-vlan)# name Faculty
    S1(config-vlan)# vlan 99
    S1(config-vlan)# name Management
    S1(config-vlan)# end

    b. Создайте такую же сеть VLAN на коммутаторе S2.

    c. Выполните команду show vlan, чтобы просмотреть список сетей VLAN на коммутаторе S1.

    S1# show vlan

    Шаг 2: Назначьте сети VLAN соответствующим интерфейсам коммутатора.

    a. Назначьте сети VLAN интерфейсам на коммутаторе S1.

    1) Назначьте узел PC-A сети VLAN для учащихся.

    S1(config)# interface f0/6
    S1(config-if)# switchport mode access
    S1(config-if)# switchport access vlan 10

    2) Переместите IP-адрес коммутатора сети VLAN 99.

    S1(config)# interface vlan 1
    S1(config-if)# no ip address
    S1(config-if)# interface vlan 99
    S1(config-if)# ip address 192.168.1.11 255.255.255.0
    S1(config-if)# end
    b. Выполните команду show vlan brief и убедитесь, что сети VLAN назначены правильным интерфейсам.
    S1# show vlan brief

    d. Используйте топологию, чтобы назначить сети VLAN соответствующим портам коммутатора S2.
    e. Удалите IP-адрес для сети VLAN 1 на коммутаторе S2.
    f. Настройте IP-адрес для сети VLAN 99 на коммутаторе S2 в соответствии с таблицей адресации.
    g. Выполните команду show vlan brief, чтобы убедиться, что сети VLAN назначены правильным интерфейсам.
    S2# show vlan brief

    Часть 3: Поддержка назначения портов VLAN и базы данных VLAN

    В третьей части лабораторной работы вам предстоит изменить назначения сети VLAN портам и удалить сети VLAN из базы данных VLAN.

    Шаг 1: Назначьте сеть VLAN нескольким интерфейсам.

    a. На коммутаторе S1 назначьте интерфейсы F0/11 – 24 сети VLAN 10.
    S1(config)# interface range f0/11-24
    S1(config-if-range)# switchport mode access
    S1(config-if-range)# switchport access vlan 10
    S1(config-if-range)# end
    b. Выполните команду show vlan brief, чтобы проверить назначения VLAN.
    c. Заново назначьте порты F0/11 и F0/21 сети VLAN 20.
    d. Убедитесь, что назначения сети VLAN настроены верно.

    Шаг 2: Удалите назначение VLAN из интерфейса.

    a. Используйте команду no switchport access vlan, чтобы удалить назначение сети VLAN 10 для F0/24.
    S1(config)# interface f0/24
    S1(config-if)# no switchport access vlan
    S1(config-if)# end

    b. Убедитесь, что это изменение сети VLAN вступило в силу.

    Шаг 3: Удалите идентификатор VLAN из базы данных VLAN.

    a. Добавьте сеть VLAN 30 в интерфейс F0/24, не вводя команду сети VLAN.

    S1(config)# interface f0/24
    S1(config-if)# switchport access vlan 30

    % Access VLAN does not exist. Creating vlan 30

    Примечание. Чтобы добавить сеть VLAN в базу данных, на современных коммутаторах больше не нужно выполнять команду vlan. Когда порту назначается неизвестная сеть VLAN, эта сеть VLAN добавляется в базу данных.

    b. Убедитесь, что новая сеть VLAN отображается в таблице VLAN.
    S1# show vlan brief

    c. Используйте команду vlan 30, чтобы удалить сеть VLAN 30 из базы данных VLAN. S1(config)# no vlan 30
    S1(config)# end
    d. Выполните команду show vlan brief. Порт F0/24 было назначен сети VLAN 30.
    S1# show vlan brief

    Примечание. Чтобы добавить сеть VLAN в базу данных, на современных коммутаторах больше не нужно выполнять команду vlan. Когда порту назначается неизвестная сеть VLAN, эта сеть VLAN добавляется в базу данных.

    e. Выполните команду no switchport access vlan на интерфейсе F0/24.

    f. Выполните команду show vlan brief, чтобы определить назначение сети VLAN для F0/24.

    Примечание. Прежде чем удалять сеть VLAN из базы данных, рекомендуется переназначить все порты, назначенные для этой сети VLAN.

    Часть 4: Конфигурация транкового канала стандарта 802.1Q между коммутаторами

    В четвёртой части лабораторной работы вам необходимо настроить интерфейс F0/1 для использования протокола динамического создания транкового канала (DTP), чтобы он мог согласовываться с транковым режимом. После выполнения и проверки настройки вам нужно будет отключить DTP на интерфейсе F0/1 и вручную настроить его в качестве транкового канала.

    Шаг 1: Для создания транковой связи на порте F0/1 используйте протокол DTP.

    По умолчанию протокол DTP на порте коммутатора 2960 настроен на динамический автоматический режим. Благодаря этому интерфейс может преобразовать канал в транковый канал, если соседний интерфейс настроен на транковый или динамический рекомендуемый режим.

    a. Настройте порт F0/1 на коммутаторе S1 для согласования транкового режима.
    S1(config)# interface f0/1
    S1(config-if)# switchport mode dynamic desirable

    *Mar 1 05:07:28.746: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
    *Mar 1 05:07:29.744: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
    S1(config-if)#
    *Mar 1 05:07:32.772: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    S1(config-if)#
    *Mar 1 05:08:01.789: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up
    *Mar 1 05:08:01.797: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

    На S2 также должны отображаться сообщения о состоянии каналов.

    S2#
    *Mar 1 05:07:29.794: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
    S2#
    *Mar 1 05:07:32.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    S2#
    *Mar 1 05:08:01.839: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up
    *Mar 1 05:08:01.850: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

    b. На коммутаторах S1 и S2 выполните команду show vlan brief. Интерфейс F0/1 больше не назначен сети VLAN 1. Транковые интерфейсы не указаны в таблице VLAN.
    S1# show vlan brief

    c. Для просмотра транковых интерфейсов выполните команду show interfaces trunk. Обратите внимание, что на коммутаторе S1 настроен рекомендуемый режим, а на S2 настроен автоматический режим.

    S1# show interfaces trunk

    S2# show interfaces trunk

    Примечание. По умолчанию доступ в транковый канал разрешён для всех сетей VLAN. С помощью команды switchport trunk вы можете определить, какие сети VLAN имеют доступ к транковому каналу. В этой лабораторной работе оставьте настройки по умолчанию, чтобы все сети VLAN могли проходить через F0/1.

    d. Убедитесь в том, что трафик сети VLAN проходит через транковый интерфейс F0/1.

    Шаг 2: Вручную настройте транковый интерфейс F0/1.

    Команда switchport mode trunk позволяет вручную настроить порт в качестве транкового канала. Эту команду следует выполнять на обоих концах канала.

    a. Измените режим порта коммутатора на интерфейсе F0/1, чтобы принудительно создать транковую связь. Не забудьте сделать это на обоих коммутаторах.

    S1(config)# interface f0/1
    S1(config-if)# switchport mode trunk

    b. Для просмотра транкового режима выполните команду show interfaces trunk. Обратите внимание, что режим изменён с рекомендуемого (desirable) на вкл (on).
    S2# show interfaces trunk

    Часть 5: Удаление базы данных VLAN

    В пятой части лабораторной работы вам предстоит удалить базу данных VLAN из коммутатора. Данную процедуру необходимо выполнять при сбросе настроек коммутатора на параметры по умолчанию.

    Шаг 1: Определите, существует ли база данных VLAN.

    Выполните команду show flash, чтобы проверить, содержится ли файл vlan.dat во флеш-памяти.

    S1# show flash

    Примечание. Если во флеш-памяти содержится файл vlan.dat, то база данных VLAN не содержит свои параметры по умолчанию.

    Шаг 2: Удалите базу данных VLAN.

    a. Выполните команду delete vlan.dat, чтобы удалить файл vlan.dat из флеш-памяти и вернуть настройки базы данных VLAN к параметрам по умолчанию. Вам понадобится два раза подтвердить удаление файла vlan.dat. Оба раза нажмите клавишу Enter.

    S1# delete vlan.dat

    Delete filename [vlan.dat]? 
    Delete flash:/vlan.dat? 
    [confirm] S1#

    b. Выполните команду show flash, чтобы убедиться, что файл vlan.dat был удалён.

    S1# show flash

    Ты знаешь, что такое безумие? Безумие - это точное повторение одного и того же действия, раз за разом, в надежде на изменение.

Просмотр 1 сообщения - с 1 по 1 (всего 1)

Для ответа в этой теме необходимо авторизоваться.

Авторизация
*
*
Регистрация
*
*
*
Генерация пароля